Autor Tema: El misterio del Eje exclavo (Solucionado)  (Leído 679 veces)

Desconectado gtzaskar

  • Ayudante
  • **
  • Join Date: Ago 2013
  • Mensajes: 58
  • Ubicación: Tenerife
El misterio del Eje exclavo (Solucionado)
« en: 06 Mayo 2019, 00:20 »
Pues como dice el asunto, llevo mas de un mes intentando solucionar un problema que no me había pasado antes, justo después de cambiar a una nueva controladora china.  No se si habrá solución.

El problema es que tengo dos transmisiones para el eje X y tengo el eje A esclavo del X en la configuración de Mach3, funciona perfectamente en todas las situaciones excepto cuando hago la Referencia a Home, donde solo funciona el Eje X y el A deja de funcionar.  He mirado todas las opciones que se me han ocurrido en la configuración pero no hay forma.  No se si a alguna alma caritativa se le puede ocurrir donde esta el problema, aunque me imagino que esta en la tarjeta china que de alguna manera no interpreta bien el código.

Gracias de antemano.
« última modificación: 13 Mayo 2019, 15:44 por gtzaskar »

Desconectado pritt

  • Gurú
  • ******
  • Join Date: Ago 2011
  • Mensajes: 1349
  • Ubicación: Tortosa (T)
Re:El misterio del Eje exclavo
« Respuesta #1 en: 06 Mayo 2019, 13:58 »
Por lo que explicas creo que te falta habilitar la casilla de "home slave with master axis" en config, general config.

Un saludo.

Desconectado gtzaskar

  • Ayudante
  • **
  • Join Date: Ago 2013
  • Mensajes: 58
  • Ubicación: Tenerife
Re:El misterio del Eje exclavo
« Respuesta #2 en: 12 Mayo 2019, 23:54 »
Gracias de antemano por la aclaración.

Mañana lo mirare por la tarde a ver si hay suerte, porque es un rollo, como lo hago, lo dejo casi en el sensor de proximidad y le dejo que de una vuelta, pero fuerza los rodamientos laterales.

Gracias.

Desconectado gtzaskar

  • Ayudante
  • **
  • Join Date: Ago 2013
  • Mensajes: 58
  • Ubicación: Tenerife
Re:El misterio del Eje exclavo
« Respuesta #3 en: 13 Mayo 2019, 15:43 »
Ya pude ir a probarlo, efectivamente ahora mueve el motor exclavo, por fin, el unico problema es que ahora cuando detecta el home de X, que es el ultimo en mirar, salta no como Home sino como final de carrera y se para, he comprobado varias veces los pines de entrada por si lo tenia mal configurado y esta todo bien, pero almenos cuando se para deja a cero el eje, osea que lo unico que tengo que hacer es quitar el reset y ya esta en home todos los ejes.

Asi que muchas gracias por la información.  En la vida lo hubiera encontrado porque pocas veces entro en cofig. ya iré aprendiendo.

Desconectado pritt

  • Gurú
  • ******
  • Join Date: Ago 2011
  • Mensajes: 1349
  • Ubicación: Tortosa (T)
Re:El misterio del Eje exclavo (Solucionado)
« Respuesta #4 en: 13 Mayo 2019, 19:01 »
Me temo que algo de la configuración te falla:

Revisa bien los pines.

Revsia bien los Soft Limits.

Revisa bien las inversiones.

El homing lo que te hace es que te busca los extremos, los referencia, no los pone a 0, luego has de ser tú el que configure adecuadamente para que cuando clicles en Goto 0, cada eje se vaya al 0 máquina que tú determines.

Un saludo.

Desconectado pritt

  • Gurú
  • ******
  • Join Date: Ago 2011
  • Mensajes: 1349
  • Ubicación: Tortosa (T)
Re:El misterio del Eje exclavo (Solucionado)
« Respuesta #5 en: 13 Mayo 2019, 19:55 »
Después de responder he pensado de que claro, te estoy hablando de cómo lo tengo yo (que creo que es lo común).

... pero desconozco cómo lo tienes tú.

En mi caso, la referencia se hace a través de los finales de carrera: Cada eje se desplaza lentamente hasta el final de carrera (has de configurar cuál de los dos y en qué dirección se realiza el desplazamiento).

Una vez ha llegado al final, se para:

https://www.youtube.com/watch?v=iM1Uh_EmeOw

Tras ello, al hacer el Goto Z (tras configurarlo para que se desplace hasta el 0 que tú quieras). Yo por ejemplo, lo tengo configurado en el centro de todos los ejes:

https://www.youtube.com/watch?v=p8z9MZsRnk4

Un saludo.

Desconectado gtzaskar

  • Ayudante
  • **
  • Join Date: Ago 2013
  • Mensajes: 58
  • Ubicación: Tenerife
Re:El misterio del Eje exclavo (Solucionado)
« Respuesta #6 en: 13 Mayo 2019, 20:27 »
Hola,
Yo tengo en la maquina unos finales de carrera mecanicos y luego tengo los home de cada eje con unos sensores inductivos, que tengo antes de los finales de carrera. Al darle a ref home busca los sensores inductivos que estan en entradas diferentes, es mas, el plugin de la controladora primero hace una busqueda rapida a unos 600 mm/min y luego la repite a unos 80 mm/min para una mejor busqueda, poniendo cada eje a 0 absoluto, todo lo hace bien hasta que hace el del eje x que aparece como si se hubiera activado el final de carrera. Pero como ya comento ya me da igual porque se pone a cero y se mueven los dos motores del eje X, así que contento.
Gracias a todos por la ayuda.

Desconectado pritt

  • Gurú
  • ******
  • Join Date: Ago 2011
  • Mensajes: 1349
  • Ubicación: Tortosa (T)
Re:El misterio del Eje exclavo (Solucionado)
« Respuesta #7 en: 13 Mayo 2019, 22:37 »
Mira en la pestaña de Imput Signals de ports and pins, si tienes configurado el  X: debes de tener el mismo puerto y pin en las 3 señales de X, límite +, límite - y home, y activados el Enabled y el Active Low.

En Homing/Limits debes de tener configurado el recorrido y el lugar del sensor home. Me explico:

En mi caso que me gusta el 0 máquina en el centro, y dado que mi X es de 262 mm de recorrido, en Soft Max pongo 131 y en Soft Min -131.

En Home off debes de poner la posición en la que está el sensor del Home: En mi caso, como utilizo el límite positivo, le pongo 131 (el máximo recorrido).

Un saludo.


Desconectado gtzaskar

  • Ayudante
  • **
  • Join Date: Ago 2013
  • Mensajes: 58
  • Ubicación: Tenerife
Re:El misterio del Eje exclavo (Solucionado)
« Respuesta #8 en: 13 Mayo 2019, 23:13 »
Ok, gracias, probaré a ver si funciona

Desconectado panasonico

  • Ayudante
  • **
  • Join Date: Dic 2017
  • Mensajes: 83
  • Ubicación: Costa Brava
Re:El misterio del Eje exclavo (Solucionado)
« Respuesta #9 en: 22 Mayo 2019, 19:26 »
Buenas Pritt.

A todo esto, quisiera saber si puedes ayudarme. Ando loco con un tema de homming con el que no doy con la solución.

Tengo un doble eje "Y" configurado correctamente de avance, parada, direccion, etc.

Cuando hago homming el eje "Y" y el "Y esclavo" se desplazan conjuntamente a encontrar el final de carrera que está uno en cada eje.  Hasta aqui perfecto, llegan cada uno a su destino, y la cnc se "escuadra" correctamente; es decir en caso de que los ejes estubieran descuadrados los obligo a cuadrarse en el home.
Bien , lo que pasa es que al llegar el primer final de carrera (supongamos que del eje Y ) se para al detectarlo correctamente, y al llegar el segundo eje, se para tambien al llegar a su respectivo final de carrera.... PERO !!!  y aqui está el problema, el motor invierte el giro hasta salir del final de carrera y me descuadra la máquina.

He intentado desactivarlo pero no hay manera, no encuentro como hay que hacerlo.

Sabrias hecharme un cable ?

Te lo agradezco.

Un saludo cordial.
"Homines, dum docent discunt"

Desconectado pritt

  • Gurú
  • ******
  • Join Date: Ago 2011
  • Mensajes: 1349
  • Ubicación: Tortosa (T)
Re:El misterio del Eje exclavo (Solucionado)
« Respuesta #10 en: 23 Mayo 2019, 12:34 »
Creo que conviene que aclares qué es lo que tienes, ¿finales de carrera (límites)? ¿homming?, ¿un interruptor para ambos?

En cualquier caso, lo que comentas no tiene mucho sentido:

Si llega al final de carrera (límite), debe de pararse y no excederlo, con lo que no debe de invertir la dirección para "salir del final de carrera".

Si se trata de homming, tampoco debería de "moverse", hasta que tú hagas un GoTo Z o cualquier otro movimiento.

Lo único que se me ocurre es que uno de los dos ejes en los que tienes dos motores, lo tengas mal configurado o cableados de diferente forma: Ten en cuenta que si los motores están instalados de forma enfrentada, lo que para uno será positivo, para el otro será negativo.

Comprueba todo lo dicho en este post.

Un saludo.

Desconectado panasonico

  • Ayudante
  • **
  • Join Date: Dic 2017
  • Mensajes: 83
  • Ubicación: Costa Brava
Re:El misterio del Eje exclavo (Solucionado)
« Respuesta #11 en: 23 Mayo 2019, 16:32 »
Buenas.

Vale gracias por la ayuda.

Un saludo
"Homines, dum docent discunt"

Foro MetalAficion

Re:El misterio del Eje exclavo (Solucionado)
« Respuesta #11 en: 23 Mayo 2019, 16:32 »

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20